Victorian Cake in IS2

So throughout my journey through is2 I’ve noticed that some of wording for the item unlocks is kinda inconsistent in what it actually means. For example, I can’t remember what items actually had these requirements but one of said items just needed you to fulfill the the requirements to get it, while the other item needed you to actually win the run for the item to unlock. Both items, however, shared the exact same item description. My problem here is that the victorian cake requires you to “have a squad size limit of 13 at any point” I’ve done this on numerous occasions and took a picture on this last run just to make sure I wasn’t going crazy. Does anyone else have this problem?


(Edit: I got lucky and was able to get 13 again but this time it worked so I guess it’s problem solved :man_shrugging:)

Just double checked and I haven’t gotten it unlocked either, and I’m pretty sure I’ve gotten at least two runs where I’ve reached the max amount of available slots.

It’s weird to me that I haven’t seen any other threads mentioning this so I’m not sure if it’s just a bug for a few people or what. Also, I was wondering if you’ve ever had the max limit in hard mode cause I’ve never touched hard mode before and think that maybe some unlocks are tied to it.

1 Like

I have it unlocked


Don’t remember when tho, CN wiki and EN wiki are having the same descriptions so I can’t help much here :feh_lucyshrug:

Also hard mode ain’t lock anything aside from hard mode only artifact which are only these


I’ve been playing normal mode only and got nearly everything unlocked :fgo_shutensip:

4 Likes

Maybe if you don’t have temporary operators in your squad?

I also have the relic unlocked. I usually recruit max 2 of those default operators.

1 Like

I gotcha, I just figured that hard mode might be the case because nothing else has worked and I’m almost 100% sure I’ve gotten 13 on numerous occasions. Also, same here with almost all items unlocked. What are you missing?

(Edit: got to 13 again. I have a video and everything. I’ll post results after I beat phantom)

Hmmm maybe. I’ll try to get 13 again without any of the generic knights and post the results. It’s just odd to me that the unlock description states nothing about filling the squad slots but just having the slots in general.

(Edit: got 13 literally next run through some tomfoolery. I have a video of me going from 11 to 13 and everything. I’ll post the results after I beat phantom.)

I think you may have been right cause it worked this time. In the past I could’ve sworn all the units were mine so idk game is weird. Thanks for the suggestion!

1 Like

You’re welcome!

Programming is hard, I can only imagine the reason for this problem. Maybe the trigger for the achievement checks for 13 unique Operator IDs in a squad, but because you had ones with the same one they only counts as one.

1 Like

Perhaps, I still think that the whole “at any point” part of the unlock and the fact that it doesn’t mention actually filling the 13 slots with units should be noted. Maybe a mistranslation?

It doesn’t count if you do it with the monthly team or the easy difficulty level. It’s possible you achieved the 13 slots on one of those runs instead.
Also for the Victorian cake while it says at any time it just means you don’t have to beat the run but the run does have to end for it to calculate the achievement so either by losing or abandoning will also make it unlock.

I’ve been working to unlock and collect every is2 item in the gallery and I also personally thought I got the Victorian cake achievement but It was during a monthly team run I noticed afterwards.

There’s only 1 instance that I got 13 on easy mode and I knew back then you don’t get unlocks in easy mode. I’ve documented 2 cases where I’ve clearly achieved 13 squad size limit and the game refused to give me the unlock. Both of said runs not only did I get “13 at any point” but I beat phantom. Like I’ve said in previous replies I think it’s either a translation issue or an underlying condition that just isn’t listed. The condition that seemed to work was suggested by someone else here who told me to try it without generic knights or premium units that aren’t mine.

Alright, to give more context to this matter
This is the original CN text


“At anytime, having at least 13 op that you can bring”
I’ve looked up around NGA and it’s just like Habatsuki said, the requirement is that you must have at least 13 different op and they can’t be temporary op

HG was being confusing with wording here but Yostar translation made it harder to understand, this isn’t the first time btw :fgo_shutensip:

4 Likes

Interesting, I’ll have my friend try it out as well. He has yet to unlock it so I’ll have him try some things so we can hopefully have a definitve unlock condition. Again I’m very grateful for the suggestions on what the solution could be because I was getting very annoyed that the conditions were fulfilled and no dice.

Have them try out by picking the same default operator. Does it work if they all are the same default one, and does it work if only one of them is.

It would be faster if someone was missing for example “have 3 vanguards” challenge.

In my latest run I was aiming for the >20 operator challenge. I had 21 operators where 2 of them were temporary (vanguard and caster). I cleared the challenge.

The programmer in me says:
“Squad size limit? No other achievement checks for it, so it would be a waste to make a separate function for it.”

“I’ll just put it to this squad operator checking function, it already has all the error checks ready.”

“The squad size check is essentially a glorified operator count check anyways.”

The error checks:

  • collect a list of operators
  • remove null values and other illegal values
  • remove duplicates, because you can’t have many of the same in AK
  • now the list is ready for challenge checks
2 Likes

Alright, I call bs. Got enough slots to 13, no temporary ops, no hallucinations, all perfectly in check, and the blasted thing still doesn’t unlock.


7 initial slots + 5 from Collectables + 1 from EXP Leveling

I don’t get it, is it bugged or is there something I’m somehow missing? Do slots from leveling not count? Cause that would suck.

It’s a bug even in CN

This CN player had the similar clear as you but didn’t unlock it until he asked for HG customer service, they asked him to record the clear for them to see, after that, it’s magically unlocked with the same clear, it’s inconsistent afaik :fgo_coffee:

1 Like

My strangest missing challenge is this one:

I have clearly completed it at least once.

2 Likes

It could have been easy mode or monthly squad, they don’t unlock relics but they do give you the little stamp.

2 Likes